x/fido2@3.1.4/package.json

A node.js library for performing FIDO 2.0 / WebAuthn server functionality
Go to latest
package.json
{ "name": "fido2-lib", "version": "3.1.4", "description": "A library for performing FIDO 2.0 / WebAuthn functionality", "type": "module", "main": "dist/main.cjs", "module": "lib/main.js", "types": "./types/main.d.ts", "scripts": { "lint": "eslint .", "lint:fix": "eslint --fix .", "build": "npm run test && npx rollup -c rollup.config.js && npm run test:dist", "test": "c8 mocha", "test:dist": "npx mocha test/dist", "report": "c8 report --reporter=text-lcov > coverage.lcov", "codecov": "codecov -e TRAVIS_NODE_VERSION", "docs": "jsdoc -c ./.jsdoc-conf.json", "publish-docs": "gh-pages --repo https://$GH_TOKEN@github.com/webauthn-open-source/fido2-lib.git --dist docs" }, "keywords": [ "webauthn", "authentication", "fido", "fido2", "web authentication", "u2f", "server" ], "author": "Adam Powers, JamesCullum, Hexagon & Contributors", "license": "MIT", "repository": { "type": "git", "url": "https://github.com/webauthn-open-source/fido2-lib" }, "bugs": { "url": "https://github.com/webauthn-open-source/fido2-lib/issues" }, "devDependencies": { "c8": "^7.11.2", "chai": "^4.3.6", "chai-as-promised": "^7.1.1", "codecov": "^3.7.0", "docdash": "^0.4.0", "eslint": "^8.14.0", "gh-pages": "^2.2.0", "jsdoc": "^3.6.7", "mocha": "^10.0.0", "rollup": "^2.72.1", "sinon": "^14.0.0" }, "dependencies": { "@hexagon/base64": "^1.0.19", "@peculiar/webcrypto": "^1.4.0", "asn1js": "^3.0.2", "cbor-x": "^1.2.1", "jose": "^4.7.0", "pkijs": "^2.3.1", "tldts": "^5.7.77" }, "eslintConfig": { "root": true, "env": { "node": true }, "rules": { "space-before-function-paren": [ "error", { "anonymous": "never", "named": "never", "asyncArrow": "always" } ], "no-mixed-spaces-and-tabs": "error", "quotes": [ "error", "double", { "avoidEscape": true } ], "comma-dangle": [ "error", { "arrays": "always-multiline", "objects": "always-multiline", "imports": "never", "exports": "never", "functions": "ignore" } ], "indent": [ "error", "tab", { "SwitchCase": 1 } ], "semi": [ "error", "always" ], "no-multiple-empty-lines": [ "error", { "max": 2, "maxEOF": 1 } ], "no-var": [ "error" ] }, "parserOptions": { "requireConfigFile": false, "sourceType": "module", "ecmaVersion": 13 }, "ignorePatterns": [ "dist/*", "test/dist/*" ], "overrides": [ { "files": [ "**/__tests__/*.{j,t}s?(x)" ], "env": { "mocha": true } } ] }}