Module

x/grammy/platform.deno.ts

The Telegram Bot Framework.
Go to Latest
interface PassportElementErrorTranslationFiles
import { type PassportElementErrorTranslationFiles } from "https://deno.land/x/grammy@v1.10.1/platform.deno.ts";

Represents an issue with the translated version of a document. The error is considered resolved when a file with the document translation change.

Properties

source: "translation_files"

Error source, must be translation_files

type:
| "passport"
| "driver_license"
| "identity_card"
| "internal_passport"
| "utility_bill"
| "bank_statement"
| "rental_agreement"
| "passport_registration"
| "temporary_registration"

Type of element of the user's Telegram Passport which has the issue, one of “passport”, “driver_license”, “identity_card”, “internal_passport”, “utility_bill”, “bank_statement”, “rental_agreement”, “passport_registration”, “temporary_registration”

file_hashes: string[]

List of base64-encoded file hashes

message: string

Error message